• We are aware that a no permission error was shown when you tried to purchase in the last 2 days, this is now fixed.

Bug Does not create tabs using nodes option

Frank

New Member
Joined
Nov 15, 2018
Messages
8
I can choose a category and it will show that category and ALL the nodes in the category, but that's the only option working for me. If I choose individual nodes, without also choosing the category, it shows nothing. If I choose the category and only some of the nodes in the category, it still shows ALL the nodes.

Generates these errors:


Server error log

  • ErrorException: Template error: Macro public:xfa_fa_picker_macros:xfa_fa_picker is unknown
  • src/XF/Template/Templater.php:586

  • Generated by: ....
  • 26 May 2020 at 6:58 PM
Stack trace
#0 [internal function]: XF\Template\Templater->handleTemplateError(512, 'Macro public:xf...', '/home/...', 586, Array)
#1 src/XF/Template/Templater.php(586): trigger_error('Macro public:xf...', 512)
#2 src/XF/Template/Templater.php(700): XF\Template\Templater->getTemplateMacro('public', 'xfa_fa_picker_m...', 'xfa_fa_picker')
#3 internal_data/code_cache/templates/l1/s0/admin/xfa_ft_tab_edit.php(94): XF\Template\Templater->callMacro('xfa_fa_picker_m...', 'xfa_fa_picker', Array, Array)
#4 src/XF/Template/Templater.php(1315): XF\Template\Templater->{closure}(Object(ThemeHouse\UIX\XF\Template\Templater), Array)
#5 src/XF/Template/Template.php(24): XF\Template\Templater->renderTemplate('xfa_ft_tab_edit', Array)
#6 src/XF/Mvc/Renderer/Html.php(48): XF\Template\Template->render()
#7 src/XF/Mvc/Dispatcher.php(418): XF\Mvc\Renderer\Html->renderView('', 'admin:xfa_ft_ta...', Array)
#8 src/XF/Mvc/Dispatcher.php(400): XF\Mvc\Dispatcher->renderView(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#9 src/XF/Mvc/Dispatcher.php(360): XF\Mvc\Dispatcher->renderReply(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#10 src/XF/Mvc/Dispatcher.php(53): XF\Mvc\Dispatcher->render(Object(XF\Mvc\Reply\View), 'html')
#11 src/XF/App.php(2178): XF\Mvc\Dispatcher->run()
#12 src/XF.php(390): XF\App->run()
#13 admin.php(13): XF::runApp('XF\\Admin\\App')
#14 {main}



Request state

array(4) {
["url"] => string(24) "/admin.php?nodes-tab/add"
["referrer"] => string(42) "https://.../admin.php?nodes-tab/"
["_GET"] => array(1) {
["nodes-tab/add"] => string(0) ""
}
["_POST"] => array(0) {
}
}
 
Last edited:

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
5,298
You have installed our Core add-on ?
 

Frank

New Member
Joined
Nov 15, 2018
Messages
8
Yes, it's installed. Can I assume that you've tested this for yourself by now and haven't been able to replicate it?
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
5,298
Wrt. the fa error yes I tested I am not getting it.

Wrt. the behavior you experienced it's the way the product is designed.
I didn't recall but checked the code.

The reason behind that is that otherwise it's impossible to maintain the nodes hierarchy.
 

Frank

New Member
Joined
Nov 15, 2018
Messages
8
Wrt. the fa error yes I tested I am not getting it.

Wrt. the behavior you experienced it's the way the product is designed.
I didn't recall but checked the code.

The reason behind that is that otherwise it's impossible to maintain the nodes hierarchy.
Hmm, thanks. My mistake then, I guess. I was under the impression that the "Applicable nodes" option would allow you to choose which nodes were shown for "Type: Nodes," but apparently that only works for the other Types. For node type it should probably be "Applicable categories."
 
Last edited:

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
5,298
Hmm, thanks. My mistake then, I guess. I was under the impression that the "Applicable nodes" option would allow you to choose which nodes were shown for "Type: Nodes," but apparently that only works for the other Types. For node type it should probably be "Applicable categories."
Yeah I should clarify that in the next update.
 
  • Like
Reactions: Frank