• This area is dedicated to the support of our xF1 add-ons. For xF2, please use the dedicated area: HERE.
  • We are aware that a no permission error was shown when you tried to purchase in the last 2 days, this is now fixed.

Bug Not a bug Edit non-sectioned document doesn't show

dcg

New Member
Joined
Jan 28, 2016
Messages
4
Document Tools > Edit Document

For documents created w/o sections. Any edits to summary, content are not shown after clicking save. Title edits are shown. However, when I go back to Document Tools > Edit Document the forum input field for summary and content have the proper edited text.

This issue does not happen for sectioned documents. Where I used the Edit button below each section.

Added here from Xenforo forums.
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
4,163
Hum, I did just what you stated and it just works perfectly for me.

Clément
 
  • Like
Reactions: dcg

dcg

New Member
Joined
Jan 28, 2016
Messages
4
I figured that it might be a cache issue and it appears that [bd]cache is the culprit. If I disable addon updates are displayed.

Interesting is the summary updates show in the thread.
So the cache issue is just the document view and only on a nonsectioned one.

FYI

I might transition to different cache if their isn't a simple solution. Any thoughts?
 
  • Like
Reactions: twisted_melon

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
4,163
Hello,

That may be because the cache has an impact on the bbcode caching, not sure honestly I don't know how [bd] cache works.

I am not an expert into cache system for xF, better ask the support.

Clément
 
  • Like
Reactions: dcg

dcg

New Member
Joined
Jan 28, 2016
Messages
4
I agree caching starts getting tricky. Thanks for the reply. I will just move away from bd
 
  • Like
Reactions: MtoR

twisted_melon

Active Member
Joined
Nov 18, 2015
Messages
303
Document Tools > Edit Document

For documents created w/o sections. Any edits to summary, content are not shown after clicking save. Title edits are shown. However, when I go back to Document Tools > Edit Document the forum input field for summary and content have the proper edited text.

This issue does not happen for sectioned documents. Where I used the Edit button below each section.

Added here from Xenforo forums.
I figured that it might be a cache issue and it appears that [bd]cache is the culprit. If I disable addon updates are displayed.

Interesting is the summary updates show in the thread.
So the cache issue is just the document view and only on a nonsectioned one.

FYI

I might transition to different cache if their isn't a simple solution. Any thoughts?
Yes I can confirm this too. Turning it off then on does help with the updated text. Not looking for help, but just confirming it is 100% the case too. :)
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
4,163
Understood but if [bd] cache changes the way the documents behave it's out of the normality.
 

twisted_melon

Active Member
Joined
Nov 18, 2015
Messages
303
Understood but if [bd] cache changes the way the documents behave it's out of the normality.
Yeah it's odd. posted mainly to say it's definitely an issue. The workaround is simply turn it off/on. That way the document will update. Hopefully this will help others. :)
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
4,163
Yeah it's odd. posted mainly to say it's definitely an issue. The workaround is simply turn it off/on. That way the document will update. Hopefully this will help others. :)
Did you asked the caching add-on author to find out what could be causing such a problem ?
 

sinbad

Member
Joined
Apr 3, 2016
Messages
11
For documents created w/o sections. Any edits to summary, content are not shown after clicking save.
same problem.
perhaps this is due to updating widgetframework to 2.5.9, maybe not. but before that it was not
It is noted that when you turn off and then turn on any addon, the content is updated.
sorry for english
 
Last edited:
  • Like
Reactions: twisted_melon

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
4,163
The caching add-on is not a standard feature from xF so it's out of the general working context of our add-on.
I am sorry but we can't afford spending time on a non default feature.