• This area is dedicated to the support of our xF1 add-ons. For xF2, please use the dedicated area: HERE.
  • We are aware that a no permission error was shown when you tried to purchase in the last 2 days, this is now fixed.

Bug Fixed Error on clicking the tournament

MattiGB

Member
Joined
Apr 2, 2016
Messages
118
An exception occurred: Argument 1 passed to XFA_Roster_ViewPublic_Helper_Club::getClubIconUrl() must be of the type array, null given, called in /vhosts/gamesboard.pl/web/library/XenForo/Template/Helper/Core.php on line 853 in /vhosts/gamesboard.pl/web/library/XFA/Roster/ViewPublic/Helper/Club.php on line 14

  1. XFA_Roster_ViewPublic_Helper_Club::getClubIconUrl() in XenForo/Template/Helper/Core.php at line 853
  2. XenForo_Template_Helper_Core::callHelper() in XenForo/Template/Abstract.php(265) : eval()'d code at line 198
  3. eval() in XenForo/Template/Abstract.php at line 265
  4. XenForo_Template_Abstract->_renderInternal() in XenForo/Template/Abstract.php at line 191
  5. XenForo_Template_Abstract->render() in XenForo/Template/Public.php at line 110
  6. XenForo_Template_Public->render() in XenForo/ViewRenderer/HtmlPublic.php at line 124
  7. XenForo_ViewRenderer_HtmlPublic->renderContainer() in XenForo/FrontController.php at line 639
  8. XenForo_FrontController->renderView() in XenForo/FrontController.php at line 158
  9. XenForo_FrontController->run() in /vhosts/gamesboard.pl/web/index.php at line 13

It's only when I want to get to team tournament.
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
4,442
Yes it is but not in roster :D, will fix tournament.
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
4,442
I don't get that when I go to a team tournament.
You are running the latest roster add-on ?

In fact I missread, it was another error I knew it was due to tournament.
 

MattiGB

Member
Joined
Apr 2, 2016
Messages
118
Yes I have the latest roster add-on installed and connected to tournaments.
Error shows when I click on team tournament (from tournament list)
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
4,442
When I click on this link it says:
Wystąpił nieoczekiwany błąd. Spróbuj ponownie.
 

MattiGB

Member
Joined
Apr 2, 2016
Messages
118
But it shows this:
An exception occurred: Argument 1 passed to XFA_Roster_ViewPublic_Helper_Club::getClubIconUrl() must be of the type array, null given, called in /vhosts/gamesboard.pl/web/library/XenForo/Template/Helper/Core.php on line 853 in /vhosts/gamesboard.pl/web/library/XFA/Roster/ViewPublic/Helper/Club.php on line 14

  1. XFA_Roster_ViewPublic_Helper_Club::getClubIconUrl() in XenForo/Template/Helper/Core.php at line 853
  2. XenForo_Template_Helper_Core::callHelper() in XenForo/Template/Abstract.php(265) : eval()'d code at line 198
  3. eval() in XenForo/Template/Abstract.php at line 265
  4. XenForo_Template_Abstract->_renderInternal() in XenForo/Template/Abstract.php at line 191
  5. XenForo_Template_Abstract->render() in XenForo/Template/Public.php at line 110
  6. XenForo_Template_Public->render() in XenForo/ViewRenderer/HtmlPublic.php at line 124
  7. XenForo_ViewRenderer_HtmlPublic->renderContainer() in XenForo/FrontController.php at line 639
  8. XenForo_FrontController->renderView() in XenForo/FrontController.php at line 158
  9. XenForo_FrontController->run() in /vhosts/gamesboard.pl/web/index.php at line 13
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
4,442
It doesn't do that for me and I didn't see that error when clikcing the link you gave me.

As I said it stated "Wystąpił nieoczekiwany błąd. Spróbuj ponownie." which I don't know the meaning.
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
4,442
Can I get admin account + ftp ? Seems your setup is specific I would need to debug
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
4,442
May it be that in this tournament you have a club which doesn't exist anymore ?
 

MattiGB

Member
Joined
Apr 2, 2016
Messages
118
I didn't remove any clubs by myself. I don't remember which clubs participated there.
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
4,442
Fixed it on your setup, @Fredxd you should fix this in Roster.

Changed the helper to:
PHP:
    public static function getClubIconUrl($club)
    {
        if (is_array($club) && !empty($club['icon_date']))
        {
            $group = floor($club['club_id'] / 1000);
            return XenForo_Application::$externalDataUrl . "/club_icons/$group/$club[club_id].jpg?$club[icon_date]";
        }

        $imagePath = 'styles/xfa';

        return "{$imagePath}/roster/club_icon.png";
    }
 

MattiGB

Member
Joined
Apr 2, 2016
Messages
118
Ok I can now see tournament bracket for teams, but still linking to team page doesn't work.
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
4,442
Yeah no worries, that is fixed in upcoming version, tested the code on your setup but then I removed it as debug mode ain't active to avoid non reverted templates.
 
  • Like
Reactions: MattiGB