• We are aware that a no permission error was shown when you tried to purchase in the last 2 days, this is now fixed.

Bug Pressing on filters gives MySQl error

Jul

New Member
Joined
Oct 30, 2018
Messages
10
Getting the following error when pressing on 'filters' within the nodes list.

Code:
XF\Db\Exception: MySQL statement prepare error [1146]: Table 'xxxx.xfa_tournament_category' doesn't exist src/XF/Db/AbstractStatement.php:228
Generated by: xxx Sep 14, 2021 at 2:21 PM
Stack trace
            SELECT 1
            FROM xfa_tournament_category
            WHERE thread_node_id = ?
            LIMIT 1
        
------------

#0 src/XF/Db/Mysqli/Statement.php(196): XF\Db\AbstractStatement->getException('MySQL statement...', 1146, '42S02')
#1 src/XF/Db/Mysqli/Statement.php(39): XF\Db\Mysqli\Statement->getException('MySQL statement...', 1146, '42S02')
#2 src/XF/Db/Mysqli/Statement.php(54): XF\Db\Mysqli\Statement->prepare()
#3 src/XF/Db/AbstractAdapter.php(94): XF\Db\Mysqli\Statement->execute()
#4 src/XF/Db/AbstractAdapter.php(150): XF\Db\AbstractAdapter->query('
            SELECT 1
        ...', 55)
#5 src/addons/XFA/Tournament/XF/ForumType/Discussion.php(42): XF\Db\AbstractAdapter->fetchOne('
            SELECT 1
        ...', 55)
#6 src/XF/Pub/Controller/Forum.php(564): XFA\Tournament\XF\ForumType\Discussion->getFilterableThreadTypes(Object(SV\CollaborativeThreads\XF\Entity\Forum))
#7 src/XF/Mvc/Dispatcher.php(350): XF\Pub\Controller\Forum->actionFilters(Object(XF\Mvc\ParameterBag))
#8 src/XF/Mvc/Dispatcher.php(257): XF\Mvc\Dispatcher->dispatchClass('XF:Forum', 'Filters', Object(XF\Mvc\RouteMatch), Object(SV\RedisCache\XF\Pub\Controller\Forum), NULL)
#9 src/XF/Mvc/Dispatcher.php(113): XF\Mvc\Dispatcher->dispatchFromMatch(Object(XF\Mvc\RouteMatch), Object(SV\RedisCache\XF\Pub\Controller\Forum), NULL)
#10 src/XF/Mvc/Dispatcher.php(55): XF\Mvc\Dispatcher->dispatchLoop(Object(XF\Mvc\RouteMatch))
#11 src/XF/App.php(2344): XF\Mvc\Dispatcher->run()
#12 src/XF.php(512): XF\App->run()
#13 index.php(20): XF::runApp('XF\\Pub\\App')
#14 {main}
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
5,753
Are you sure install went fine ?

You seem to be missing the category table in the database.