• We are aware that a no permission error was shown when you tried to purchase in the last 2 days, this is now fixed.

Bug Resolved Server Error - Block User page

naia

New Member
Joined
Feb 13, 2021
Messages
8
Hello, this error occurs on the block user page.
ErrorException: Template error: [E_USER_WARNING] Macro public:xfa_core_macros:check_uncheck_all is unknown src/XF/Template/Templater.php:632
Code:
#0 [internal function]: XF\Template\Templater->handleTemplateError(512, '[E_USER_WARNING...', '/var/www/kinmun...', 632, Array)
#1 src/XF/Template/Templater.php(632): trigger_error('Macro public:xf...', 512)
#2 src/XF/Template/Templater.php(745): XF\Template\Templater->getTemplateMacro('public', 'xfa_core_macros', 'check_uncheck_a...')
#3 internal_data/code_cache/templates/l1/s17/public/xfa_extmod_block_user.php(401): XF\Template\Templater->callMacro('xfa_core_macros', 'check_uncheck_a...', Array, Array)
#4 src/XF/Template/Templater.php(1626): XF\Template\Templater->{closure}(Object(SV\StandardLib\XF\Template\Templater), Array, NULL)
#5 src/XF/Template/Template.php(24): XF\Template\Templater->renderTemplate('xfa_extmod_bloc...', Array)
#6 src/XF/Mvc/Renderer/Html.php(48): XF\Template\Template->render()
#7 src/XF/Mvc/Dispatcher.php(458): XF\Mvc\Renderer\Html->renderView('XFA\\ExtendedMod...', 'public:xfa_extm...', Array)
#8 src/XF/Mvc/Dispatcher.php(440): XF\Mvc\Dispatcher->renderView(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#9 src/XF/Mvc/Dispatcher.php(400): XF\Mvc\Dispatcher->renderReply(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#10 src/XF/Mvc/Dispatcher.php(58): XF\Mvc\Dispatcher->render(Object(XF\Mvc\Reply\View), 'html')
#11 src/XF/App.php(2326): XF\Mvc\Dispatcher->run()
#12 src/XF.php(488): XF\App->run()
#13 index.php(20): XF::runApp('XF\\Pub\\App')
#14 {main}
Code:
array(4) {
  ["url"] => string(38) "/extended-moderation/block-user?user_id=57023"
  ["referrer"] => string(26) "<MY DOMAIN REMOVED>"
  ["_GET"] => array(1) {
    ["user_id"] => string(5) "57023"
  }
  ["_POST"] => array(0) {
  }
}
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
5,645
Oh, I forgot to state the dependencies, you need to install our xfa core add-on (free from our shop)
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
5,645
Hum no the dependency is there, you installed it ?
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
5,645
That's really odd, the data is excepted to be there.
Do you have a template called xfa_core_macros
 

naia

New Member
Joined
Feb 13, 2021
Messages
8
That's really odd, the data is excepted to be there.
Do you have a template called xfa_core_macros
Template does not exist - but the addon is installed [XFA] Core 1.8.0. Bizarre.