What's new
Xen Factory

Register today to become a member! Once signed in, you'll be able to start purchasing our products, ask questions, request support and suggest new ideas!

  • We are aware that a no permission error was shown when you tried to purchase in the last 2 days, this is now fixed.

Fixed Tournaments uninstall error

André

New Member
I just tried uninstalling Tournaments but it's giving this error:

Error: Call to protected method XF\AddOn\AbstractSetup::db() from scope XFA\Tournament\Install\Uninstall in src/addons/XFA/Tournament/Install/Uninstall.php at line 41
XFA\Tournament\Install\Uninstall::runStep3() in src/addons/XFA/Tournament/Setup.php at line 251
XFA\Tournament\Setup->uninstallStep3() in src/XF/AddOn/StepRunnerUninstallTrait.php at line 61
XFA\Tournament\Setup->uninstallStepRunner() in src/XF/AddOn/StepRunnerUninstallTrait.php at line 28
XFA\Tournament\Setup->uninstall() in src/XF/Admin/Controller/AddOn.php at line 657
XF\Admin\Controller\AddOn->actionUninstall() in src/XF/Mvc/Dispatcher.php at line 352
XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 259
XF\Mvc\Dispatcher->dispatchFromMatch() in src/XF/Mvc/Dispatcher.php at line 115
XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 57
XF\Mvc\Dispatcher->run() in src/XF/App.php at line 2487
XF\App->run() in src/XF.php at line 524
XF::runApp() in admin.php at line 13

Any ideas?
Screenshot_2024-01-05-15-20-57-38_40deb401b9ffe8e1df2f1cc5ba480b12.jpg
 

André

New Member
Yeah so I'm noticing unusual glitchiness on the forum now, nothing major, but noticable.

Here's the current list of errors:

Screenshot_2024-01-05-16-11-12-96_40deb401b9ffe8e1df2f1cc5ba480b12.jpg
 

André

New Member
Sorry to be a pain, I ahhhh, lol, probably really need a hand resolving this asap coz it's apparently also inhibiting successful installation of other add-ons too.

Currently this ['Tournaments'] add-on is stuck in some sorta pending state and now ['Search Improvements'] is apparently stuck pending as well.
 

André

New Member
Unsure if it's related but about 20-30 minutes ago while logged in at my forum on mobile via the PWA—suddenly the site refreshed to a blank white page saying there's an upgrade in progress.

I tried logging in with the PWA several times and kept getting the same blank page, so I logged in on mobile using the Brave browser and apparently the forum was completely fine.

After 15 or so minutes I re-tried logging in with the PWA and everything was back to normal again.
 

Clement

Freaky Coder
Staff member
For now, here is a fix.

Go to src/addons/XFA/Tournament/Install/Uninstall.php.

Replace:
PHP:
$db = $setup->db();

By:
PHP:
$db = \XF::db();
 

André

New Member
For now, here is a fix.

Go to src/addons/XFA/Tournament/Install/Uninstall.php.

Replace:
PHP:
$db = $setup->db();

By:
PHP:
$db = \XF::db();
Honestly I have no idea where that is.

Is it in templates or something?
 

André

New Member
For now, here is a fix.

Go to src/addons/XFA/Tournament/Install/Uninstall.php.

Replace:
PHP:
$db = $setup->db();

By:
PHP:
$db = \XF::db();
I can't seem to find where this is.

Is this something I need access to the database to do?

Coz I'm on XF Cloud.
 

Clement

Freaky Coder
Staff member
No these are files.
Ohhhhhh if you are on XF Cloud you can do that... and you can't install expect with an archive so right now this won't help.
I'll release a bug fix version but that will be in coming days.
 

André

New Member
Sorry to be a pain.
Could I request an ETA on an update please?

The reason I ask is because this pending uninstall is actually inhibiting numerous basic functions and I simply haven't been able to do a lot of regular—as well as important—tasks since it started.
Eg: I can't change user group permissions, can't analyze permissions, can't change node permissions, etc, etc...

And unfortunately a new-(*although probably unrelated)-issue has been brought to my attention this morning and so far I can not do anything to resolve it because this pending uninstall keeps giving me the error notification.
 

André

New Member
Update: Took most of the day but eventually we've found that this mornings unexpected issue is definitely being caused by the pending 'Tournaments' uninstall.

The issue appears to have been occuring the entire time 'Tournaments' has been installed too, although we simply didn't notice until a newly registered member unwittingly stumbled upon it.

We've somewhat figured out a temporary solution but urgently need help resolving this properly asap.

I will gladly provide full super admin access, and whatever else you may require if need be.
 

Clement

Freaky Coder
Staff member
Did you at least disable the add-on or you don't see it ?

If you don't see it the update won't fix it because you will first need to update the add-on and then uninstall it.
 

André

New Member
Did you at least disable the add-on or you don't see it ?

If you don't see it the update won't fix it because you will first need to update the add-on and then uninstall it.
Yessir, infact disabling it was actually the temporary solution.

Tbh I didn't expect the disable option would even work and only tried it as a desperate last resort. Lol, I couldn't believe it worked.

But yeah, I can still see the add-on and am pretty sure I can re-enable it too.

Andy from xf2addons is currently having a look at some 'orphaned posts' that need deletion and I'm sure he's probably going to notice the 'Tournaments' situation.

I'm kinda embarrassed about the whole thing aye mate. I mean, it's my fault of course. Just really sucks when I'm helpless to correct my own screw-ups like this.
 

André

New Member
No worries, I'll try to provide a fixed version this week
Hope you're ok mate. I realize you've been having a rough time recently and I'm very sorry for having to bother you with this unexpected issue.

Just wanted to let you know, to my complete surprise, Andy @xf2addons has voluntarily been having a look at fixing it too. He's an incredible individual imo.
I'll keep you updated on how it goes.
 

André

New Member
No worries, I'll try to provide a fixed version this week
Hey the absolutely legendary mr Andy @xf2addons managed to modify a fix for us.

I was able to rebuild the pending version and then successfully uninstall without any issues.

Everything looks good now.
 

Clement

Freaky Coder
Staff member
Thanks mate, yeah my life has been hectic these days...

Andy is a nice individual, very keen to help.
Technically speaking I don't his work to be of top quality but he tends to get better over the year.

I didn't find the time to work on the fix as I haven't been on a lot as you could see.
 

André

New Member
Thanks mate, yeah my life has been hectic these days...

Andy is a nice individual, very keen to help.
Technically speaking I don't his work to be of top quality but he tends to get better over the year.

I didn't find the time to work on the fix as I haven't been on a lot as you could see.
Glad you're ok man.
 
Top