What's new
Xen Factory

Register today to become a member! Once signed in, you'll be able to start purchasing our products, ask questions, request support and suggest new ideas!

  • This area is dedicated to the support of our xF1 add-ons. For xF2, please use the dedicated area: HERE.
  • We are aware that a no permission error was shown when you tried to purchase in the last 2 days, this is now fixed.

Support Resolved Thread covers do not appear any more


New Member
I use extended cover for forums and threads. Everything worked fine, but now I realized a very strange behaviour.
  • All existing thread covers disappeared, the forum covers are still available.
  • When I try to add a new cover to a thread with appropriate permission I can see the "Manage Cover" button. I can upload an image for the thread cover, but if I click save no cover image appears. the "Manage cover" button has disappeared.
What can I do?

regards, rhodes


  • thread_cover.JPG
    87.4 KB · Views: 5
  • thread_cover_2.JPG
    83.2 KB · Views: 5


Staff member
Can you send me admin access by PM and can you enable debug before


New Member
What was the fix on this? I am not seeing the profile covers that I once had prior to update. I would like to see if maybe I missed the same radio buttons or something.


New Member
Yes, user groups and options for the addon was both checked. I wasn't sure if addon upgrades were the reason so I updated all of them today. Since I have the admin account, I have all permissions granted but the manage cover still doesn't appear. I am currently making the last update and I will go through the settings and permissions one more time just to be 100% that I exhausted my issues. Was it the permissions that was wrong with the OP?


New Member
It was indeed the user permissions. I swear they were all ticked and tripled checked. I went back just a second ago and they were not. I can view it so we are good. I just have to adapt to the new "top" position. The answer is user group permissions for this thread :)